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Scope of work

› This document explains how to set up and use the CYT4BF evaluation kit, which mounts the 

CYT4BFBCH device. It also describes debugging with single-core and multi-core applications in 

the ModusToolbox™ (MTB) environment.

› ModusToolbox™ tools package version

– 3.0.0

› Device

– The TRAVEOTM T2G CYT4BFBCH device is used in this code example.

› Board

– The TRAVEOTM T2G KIT_T2G-B-H_EVK board is used for testing.



3Copyright © Infineon Technologies AG 2022. All rights reserved.002-36716 **, 2022-12-08

Getting started

› This section explains the hardware setup. The following table lists the prerequisites for the setup.

Quantity Description Remarks

1 KIT_T2G-B-H_EVK CYT4BF evaluation kit

1 Micro USB cable For power and communication

1 PC With USB port

1 ModusToolbox 3.0 Downloaded from the web
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Getting started (contd.)

› Connection setup

– Connect the USB cable from the PC to the evaluation kit. The PC powers the evaluation kit via 

the USB cable (5V). 
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ModusToolbox™ setup

› Launch ModusToolbox™

– The Eclipse IDE is installed in the following directory by default:

<install_path>\ModusToolbox\ide_<version>\eclipse\

– To launch the Eclipse IDE:

– On Windows, select the Eclipse IDE for ModusToolbox™ <version> item from the Start

menu

– For other operating systems, run the "modustoolbox" executable file

– When launching the Eclipse IDE, there is an option to select the workspace location on your 

machine. This location is used by the IDE for creating and storing the files as part of application 

creation for a particular platform. The default workspace location is a folder called "mtw" in your 

home directory. You may add additional folders under the "mtw" folder or to choose any other 

location for each workspace.

– For more details about Eclipse, see the Eclipse documentation and the Eclipse survival guide.

https://community.infineon.com/docs/DOC-15617
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ModusToolbox™ setup (contd.)

› Create an application

› Choose the board support package (BSP)

– To choose the BSP, do one of these:

– Click the New Application link in the Eclipse 

IDE Quick Panel

– Select File > New > ModusToolbox™ 

Application
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ModusToolbox™ setup (contd.)

– These commands launch the Project Creator tool, which provides several applications for use with 

different development kits, and the kits available may change over time. This example uses the 

KIT_T2G-B-H_EVK kit.

– For more details about using this tool, see the Project Creator user guide

https://www.infineon.com/dgdl/Infineon-ModusToolbox_Project_Creator_Guide_3-UserManual-v01_00-EN.pdf?fileId=8ac78c8c7d718a49017d99bcabbd31e5&utm_source=cypress&utm_medium=referral&utm_campaign=202110_globe_en_all_integration-files
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ModusToolbox™ setup (contd.)

› Select application

– On the Choose Board Support Package (BSP) – Project Creator 2.0 window, click Next > to open the Select 

Application page

– This page lists various applications available for the selected kit. As you choose an application, a description displays on 

the right. You can select multiple applications for the selected BSP by enabling the check box next for those applicable.

› For this example:

– Select the check box next to the "Hello 

World" application and "Multicore Empty 

APP" application

– If desired, type a name for the application 

under New Application Name. Do not use 

spaces in the application name. In this 

case, we use the default "Hello_World" and 

"Multicore_Empty_App" as the name.
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ModusToolbox™ setup (contd.)

› Create application

– Click Create to begin the project creation process.

– When complete, the Project Creator tool closes automatically. After several moments, the application opens with the 

Hello_World and Multicore_Empty_App in Project Explorer, and the README.md file opens in the file viewer.
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Download and debug with evaluation kit

› The following types of applications are created:

– Single core application (Hello_World): 

– This application contains the prebuilt CM0+ image, and the main application function runs on the CM7_0 core. The 

prebuilt CM0P image only starts CM7 cores and puts CM0+ core into Deep Sleep mode. 

– For details on the prebuilt CM0+ image, please refer to CAT1 Cortex M0+ prebuilt images.

– Multi-core application (Multicore_Empty_App): 

– This application contains the CM0+ project, CM7_0 project, and CM7_1 project. 

– CM0+ and CM7 can do normal code execution, but from an architectural point, only CM7 is considered the application 

core (CM7 cores for primary processing and CM0+ core for peripheral and security processing). After a reset, the 

default core is always the CM0+ core. To enable the CM7 core, CM0+ must call Cy_SysEnableCM7(). 

https://github.com/Infineon/cat1cm0p
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Download and debug with evaluation kit (contd.)

› Debugging with single core application:

1. Build the application

– a) Select the Hello_World project in the Project 

Explorer window and click on the Build 

Hello_World Application shortcut under the 

Hello_World group in the Quick Panel. It selects 

the Debug build configuration and compiles/links 

all projects that constitute the application.

– b) The Console view lists the results of the build 

operation, as the following figure shows.

– If you encounter errors, revisit previous steps to 

ensure that you accomplished all the required 

tasks.
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Download and debug with evaluation kit (contd.)

2. Debug the application:

– The CYT4BF evaluation kit has a KitProg3 

onboard programmer/debugger. It supports 

Cortex® Microcontroller Software Interface 

Standard - Debug Access Port (CMSIS-DAP). 

See the KitProg3 user guide for details.

– ModusToolbox™ software uses the OpenOCD

protocol to program and debug applications on 

the CYT4BF MCU devices. ModusToolbox™ 

software will identify the device on the kit only 

if the kit is running KitProg3.

– In the Quick Panel, click the Hello_World

Debug (KitProg3) link under Launches.
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Download and debug with evaluation kit (contd.)

– If needed, the IDE builds the application, and messages display in the Console. If the build is 

successful, the IDE switches to debug mode automatically, as the following figure shows. 

– If you want to open the disassembly window,  click Window > Show View > Disassembly.

3. Click the Resume icon or press the F8 to start execution. LED1 should start blinking.

– You can also use the function keys in the Debug window: Resume (F8), Step Into (F5), Step Over (F6), Terminate 

(Ctrl+F2).

LED1
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Download and debug with evaluation kit (contd.)

› Debugging with multi-core application:

1. Build the multi-core application

– a) In the Project Explorer window, click the 

Multicore_Empty_App project.

– b) Click on the Build Multicore_Empty_App

Application shortcut under the 

Multicore_Empty_App group in the Quick 

Panel. It selects the Debug build configuration 

and compiles/links all projects that constitute the 

application.

– c) The Console view lists the results of the build 

operation, as the following figure shows.

– If you have selected Multicore_Empty_App, you 

can also select Build Project from the Project

menu or the right-click menu.
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Download and debug with evaluation kit (contd.)

2. In the Quick Panel, click the 

Multicore_Empty_App MultiCore (KitProg3) 

link under Launches.
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Download and debug with evaluation kit (contd.)

– This will automatically program the CM0P, 

CM7_0, and CM7_1 code into the flash 

region of respective cores; then, the IDE 

switches to debug mode automatically, as 

the following figure shows.

– CM0P debug session is started and halted 

at the beginning of the main () function, 

CM7_0 and CM7_1 debug session started, 

and CPU is not yet started in the following

figure.
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Download and debug with evaluation kit (contd.)

3. Place a breakpoint in the cybsp_init()

API in the mian.c of CM7_0 core,  you can also 

place another breakpoint in main.c of CM7_1 

core. CM7_0 core and CM7_1 core will start 

executing after being enabled by CM0+ core. 

You can debug three cores simultaneously.

› To place a breakpoint at the target instruction, 

click the white space between the editor 

window (left pane).
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Download and debug with evaluation kit (contd.)

4. Click the Resume icon or press the F8 in the 

CM0P project to start execution.

› After executing 
Cy_SysEnableCM7(CORE_CM7_0, 

CY_CORTEX_M7_0_APPL_ADDR) and 

Cy_SysEnableCM7(CORE_CM7_1, 

CY_CORTEX_M7_1_APPL_ADDR), CM7_0 

core and CM7_1 core will be enabled and the 

execution will be halted at the very beginning 

of CM7's main () function.

› You can click the Resume icon or press the 

F8 in the CM7_0 and CM7_1 project, the 

execution will reach the breakpoint in the 

CM7_0 project and CM7_1 project. You can 

now continue to debug the code from CM7 

cores.
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Troubleshooting

› Connection troubleshooting

– Error: Evaluation kit is not detected on the target system  

– Connect the USB cable that comes with the evaluation kit. Other USB cables may not connect data lines

– Make sure LED D5 is ON (CMSIS-DAP mode). If not, press SW3 to change the KitProg3 device mode

– If LED D5 is ON (CMSIS-DAP mode), change the KitProg3 device mode by pressing SW3. Now LED3 blinks 

smoothly. Then try to reconnect the debug session. Later, check if this works independently; stop the debug session 

again and switch the KitProg3 device mode to “LED D5 is always ON” (CMSIS-DAP mode)

› Driver troubleshooting

– Error: Driver is not detected on the target system or “KitProg3” is not visible  

– For more information on the supported driver, see the KitProg3 user guide

› Debugger troubleshooting

– Error: While programming the XMC7000 device, the CMSIS-DAP device is not found  

– Check the USB cable connection and the state of LED3 (LED should be ON for CMSIS-DAP mode)

› Key points

– The prebuilt CM0+ image should be disabled with the multi-core application; you must add the 

XMC7xDUAL_CM0P_SLEEP to DISABLE_COMPONENTS for XMC7xxxD device in the project CM7_0 Makefile

https://www.infineon.com/dgdl/Infineon-KitProg3_User_Guide-UserManual-v01_00-EN.pdf?fileId=8ac78c8c7d0d8da4017d0f01221f1853&utm_source=cypress&utm_medium=referral&utm_campaign=202110_globe_en_all_integration-dev_kit
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IMPORTANT NOTICE

The information given in this document

shall in no event be regarded as a

guarantee of conditions or

characteristics

(“Beschaffenheitsgarantie”) .

With respect to any examples, hints or

any typical values stated herein and/or

any information regarding the

application of the product, Infineon

Technologies hereby disclaims any and

all warranties and liabilities of any kind,

including without limitation warranties of

non-infringement of intellectual property

rights of any third party.

In addition, any information given in this

document is subject to customer’s

compliance with its obligations stated in

this document and any applicable legal

requirements, norms and standards

concerning customer’s products and any

use of the product of Infineon

Technologies in customer’s applications.

WARNINGS

Due to technical requirements products

may contain dangerous substances. For

information on the types in question

please contact your nearest Infineon

Technologies office.

Except as otherwise explicitly approved

by Infineon Technologies in a written

document signed by authorized

representatives of Infineon

Technologies, Infineon Technologies’

products may not be used in any

applications where a failure of the

product or any consequences of the use

thereof can reasonably be expected to

result in personal injury.

The data contained in this document is

exclusively intended for technically

trained staff. It is the responsibility of

customer’s technical departments to

evaluate the suitability of the product for

the intended application and the

completeness of the product information

given in this document with respect to

such application.

For further information on the product,

technology, delivery terms and

conditions and prices please contact

your nearest Infineon Technologies

office (www.infineon.com).
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